A-A+

Linux被曝重大漏洞:这也太低级了

2015年12月22日 未分类 Linux被曝重大漏洞:这也太低级了已关闭评论 阅读 15 次

  GRUB(Grand Unified Bootloader) 2是大部分Linux操作系统的开机管理程序,日前,它被曝出现了一个重大漏洞,而且十分低级...

新浪科技报道称,瓦伦西亚科技大学网络安全小组研究人员Hector Marco与 Ismael Ripoll在Grub 2中,发现存在一项整数下溢(integer underflow)漏洞,编号CVE-2015-8370。

通过该漏洞成功入侵的黑客可进入GRUB的Rescue Shell,进而提升权限、复制磁盘信息、安装RootKit、或是摧毁包括GRUB在内的任何资料,即使磁盘加密也可能遭到覆写,导致系统无法工作。

研究人员发现该漏洞的攻击方法相当简单:

只需在GRUB要求输入用户名时,连续按28次倒退键,就可进入Rescue Shell。IT管理员只需按照此方法操作,若看到系统重启,或是进入救援模式,即可判断自己系统有此漏洞。

令人震惊的是,从2009年12月发行的1.98版到2015年12月的2.02版,GRUB 2都存在这项漏洞,不过攻击者需要直接接触到机器才能进行攻击。

目前,包括Redhat、Ubuntu 及 Debian在内的Linux系统提供商已迅速修补这项漏洞,Marco与Ripoll也提供了紧急修补程序供下载安装。

评论已关闭!

Copyright © 理处言语然自 保留所有权利.   Theme  Ality 京ICP备07032740号

用户登录

分享到: